hi all

anybody has the idea of opening an android project in eclipse behind a proxy.

i m able to open a the project . the emulator is opening, but the intternet is not working.

please tell me if there is a configuration file to do those proxy setings.

although i m able to work on emulator in standalone mode(without opening project in  eclipse) and the internet is working when i am putting the settings in the comand promt.

please help 

You need to be a member of Mobile QA Zone to add comments!

Join Mobile QA Zone

Email me when people reply –


  • Gud to know, enjoy testing.

  • The Solution I provided above is 100% working..

    Cheers!! enjoy testing

  • well vaibhav... i find the solution... and thank you all......

     the correct solution is

    when you are entering the proxy name and proxy port..

    ask your admin(ofice admin department) to provide you the proxy ip address and not the proxy name...

    remember proxy ip address(like and not the proxy name(proxyxyz).

    hope this will help all other members......

    thank you again

  • Hi Pavan, 

    its strange that the Network settings are not working. please keep network settings as mentioned in stack overflow thread and try below suggestion - 

    Go to Computer - Properties - Advanced System Settings - Advanced - Environment Variables 

    Add New Variable 

    Variable Name should be your proxy server name 

    Value should be port address. 

    pls try this and let us know



  • Vadi... thanks.. but this by this method its not working.. .i m able to start with internet using cmd promp... but when i run an aplication from eclipse (Run as Android app) the emulator is not internet functional

  • Hi Pawan,

    Refer the below link




This reply was deleted.
    results->result as $result) { ?>
  1. jobtitle;?>
    company;?>(formattedRelativeTime;?>)city;?>, state;?>
    Welcome to Mobile QA Zone, a Next Generation Software Testing Community.Invite your friends to join this community.Write to us to become a featured member.