I have an apk file and successfully installed over emulator. Also, I know that my target package is correct but I am getting the same error "Test run failed: Unable to find the target package"

Can anyone please help me how to resolve this issue. This is my AndroidManifest.xml

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
android:versionName="1.0" >
<uses-sdk android:minSdkVersion="8" />
<supports-screens android:anyDensity="true" />
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
<uses-permission android:name="android.permission.RUN_INSTRUMENTATION" />
<uses-permission android:name="android.permission.READ_USER_DICTIONARY" />
android:targetPackage="com.WhatsApp" />
android:targetPackage="com.WhatsApp" />
android:label="@string/app_name" >
<uses-library android:name="android.test.runner" />

You need to be a member of Mobile QA Zone to add comments!

Join Mobile QA Zone

Email me when people reply –


  • might be ur .apk file wasn't generated properly. Try to get with another one.

    • I will try with new apk file and let you know soon about it.

    • Right now my app is working fine.

  • I tried all links available at https://www.google.co.in/search?sclient=psy-ab&q=unable+to+find...

    unable to find instrumentation target package com.google.android.music - Google Search
  • Which OS u r using in ur emulator ? ur SDK version - 8.

    • I didn't get it.

      I am using AVD_Nexus_One. API level is 17

This reply was deleted.
Welcome to Mobile QA Zone, a Next Generation Software Testing Community.Invite your friends to join this community.Write to us to become a featured member.